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I. Preparing your workspace in Adobe Acrobat Professional 
The first time you tag a PDF for accessibility there are a few steps you’ll need to take to set up 
your workspace. These steps only need to be performed once: 

1. Open a PDF 
2. On the very left edge and halfway down the screen, click the small arrow to expand the 

Navigation Pane if it isn’t already expanded. 
3. You will need to add a few icons to the list of defaults. To do this, right click in the empty 

space below the existing icons and select Tags. Repeat the previous steps and add 
Content. This will add the two new icons to the list. 

4. From the Tools menu on the right side of the screen, select Accessibility to expand the 
accessibility menu. If Accessibility is not in the list of tools, enter Accessibility into the 
Search Tools… field. When Accessibility shows up under the search field, right click on it 
and choose Add Shortcut from the menu and close the search field. 

5. From the Accessibility tools select Reading Order. Then check Show tables and figures. 

II. Document Properties 
To open the documents properties, click File > select Properties… 

TEST 
• The Description tab has the Title field filled out with a description of the document and Tagged 

PDF is set to Yes 
• The Security tab has Content Copying for Accessibility set to Allowed 
• The Initial View tab under Window Options > Show is set to Document Title 
• The Advanced tab has the proper language selected 

REMEDIATE 
On the Description tab fill in the fields for Title, Author, and Subject. The title should be a brief 
description of what the document is. The Author can be the name of the agency with or 
without the directorate/office. Subject can be the same as the Title or a more detailed 
description of the contents of the document.  
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Check under the Advanced group that Tagged PDF is set to Yes. 

On the Security tab make sure No Security is chosen. If you need to use security, use the 
Change Settings… button to set Content Copying for Accessibility to Allowed. 
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On the Initial View tab change the dropdown for the Show field: to Document Title instead of 
File Name. 

 

On the Advanced tab make sure the Language is set instead of blank. 

 

Click the OK button to close the Document Properties window. 

NOTE: 
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If the PDF has file attachments or is a collection of documents combined into one PDF, open 
each individual document in the portfolio and test for compliance. 

 

All or part of a PDF may be compiled from scanned pages but should be avoided unless 
necessary for reasons such as legal documents with signatures. Scanned pages are an image of 
the original. Screen readers cannot infer meaning from just a picture. Optical Character 
Recognition (OCR) may be used to recognize the images of text in the PDF. 

Click View > Tools > Enhance Scans > Open > click the Recognize Text dropdown 
button in the newly opened toolbar and choose In This File. Choose the pages you want to 
scan and the language > click the Recognize Text button. 

III. Elements Tagged for Accessibility 
Screen readers rely on tags to interpret the document structure (headings, paragraphs, lists, 
images, data tables, forms, and other objects). All meaningful text and objects must correspond 
to a tag, and the order of the tags must follow the visual/logical order of the document. 

Selecting the plus symbol to the left of a tag will expand the tag and its child element, which is 
the content on the page that the tag is associated with. 
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TEST 

• Open the Tags tree 
• Expand the tags tree to see the individual tags for each element 
• Select the first tag to highlight it and use the arrow keys to move down the list of tags, 

expanding container elements as necessary, and watch the highlighted content in the body of 
the document. Tags must follow the visible logical layout of the page. 

REMEDIATE 

Below is a list of the most common PDF tags. All tags are case sensitive. Span tags are new to 
Adobe and are caused from different text formatting. If you find Span tags in your document, 
you can leave them in place as screen reader software does not read them. When tagging a 
PDF, be sure to save often. Most actions involved in tagging a document cannot be undone. 

Be sure to delete any empty tags (tags without a plus or minus sign next to them). 
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<Artifact> Hides the element from screen readers 
<Document> The root element of a document’s 
tag tree 
<Part> A part element defines a large division of a 
document and may group smaller divisions 
together, such as Article, or Section elements. 
<Art> Article – A self-contained body of text 
considered to be a single narrative. Often 
interchangeable with <Part> 
<Sect> Typically a component of a Part or Article 
element, e.g., a section of the document 
<P> Paragraph 
<H1> Heading 1 – Recommended for the title and 
highest section level of a document 
<H2> Heading 2 
<H3> Heading 3 
<H4> Heading 4 
<H5> Heading 5 
<H6> Heading 6 
<Figure> Image/graphic 
<Link> Hyperlink 
<L> List 
<LI> List item 
<Lbl> List Label – bullet, number, or icon 
<LBody> List body 
<Table> Table 
<TR> Table Row 
<TH> Table Header Cell 
<TD> Table Data Cell 
<TOC> Table of Contents 
<TOCI> Table of Contents Item 
<Reference> Link in a Table of Contents Item 
<Footnote> linked to text in the body 
<Caption> Nested inside a <Figure> tag  
<Form> Form field 
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Designating Headings and Blocks of Text 
Headings are used to break-up content and make finding information easier. Screen readers 
cannot infer meaning from just formatting, like bold or underline, so visual headings must 
correspond to a heading tag (i.e. H1, H2, H3) and heading tags must match the visual outline. 

 

To change a tag, open the Tag tree and do one of the following to find a specific tag: 

• User the arrow keys to move through the tag tree until you find the tag used for the element 
you wish to change 

• Select the element by dragging your cursor over it to highlight it > select the menu icon in the 
Tags Pane and select Find tag from selection 

There are 3 ways to change a tag: 

1. Highlight the text in the tag between the brackets and type in the correct text 
2. Open the Touch Up Reading Order window by selecting Reading Order under the Accessibility 

tools > click the number to the left of the grey box surrounding the desired text > and choose 
the correct button in the Touch Up Reading Order window 

3. Right click the tag in the tag tree > select Properties > change the tag Type using the drop-down 
arrow 

Structure of Lists 
In Adobe Acrobat, each list structure must consist of a parent List <L> tag and subsequent list 
item <LI> tag for each item in the list. If there are a total of eight fruits listed, then there needs 
to be eight <LI> tags under the <L> tag. Each <LI> tag should (for best practice) contain a label 
<Lbl> tag that includes the number or bullet and a list item body tag <LBody> that contains the 
text of the item. Pay attention to lists that span across multiple pages. If a list continues on to the 
next page, it is important that the list items are all under one <L> tag. 
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Below is an example of proper list structure. 

Example List: 

• Oranges 
• Grapes 
• Apples 

Example List Structure: 

 
A sub-list (or nested list) must be structurally under, as a child, the list item to which it is related. 
It is placed after the text of the parent list item. 

Example sub-list: 

• Oranges 
• Grapes 
• Apples  

o Granny Smith 
o Orchard 
o Sour Apple 

• Strawberries 
• Cherries 
• Cantaloupe 
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Example sub-list structure: 

 

Headers & Footers 
Repeated content should be hidden from assistive technology. This information should be 
properly tagged in the first instance and then every other instance tagged as an Artifact, as 
described at the end of section IV. 

Reading Order 
The Tags Tree establishes the logical structure of the document, as well as the logical reading 
order for assistive technology, such as screen reader software. To rearrange the tags simply 
click a tag and hold down the mouse button as you drag it to the correct location. 

IV. Figure Elements and Alternative Text 
Screen readers cannot infer meaning from images and other objects (pictures, images of text, 
charts, diagrams, shapes, icons with hyperlinks, etc.). Meaningful images must be accompanied 
by text that describes the purpose or function of the image. Images of text, or images that 
contain text (i.e. logos, or agency seals) should have the text in the image included in the 
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alternative text. Decorative images, or images that do not lend any new information or 
understanding of the content, should be tagged as Artifacts to hide the image from assistive 
technology. Always check the surrounding text of an image to see if the information given in 
the image is already given in surrounding text. 

TEST 

To verify that useful alternative text was used for images: 

• Scroll through all pages to ensure all images are tagged as a Figure 
• Select Set Alternate Text under the Accessibility tools 
• Using the arrow buttons to cycle through and check that there is alternate text for each image 

and that the text conveys the purpose and/or function of the image or object 
• For images of text, check that the descriptive text matches the text contained in the image 

verbatim 

REMEDIATE 

To add alternative text to an image, with the Touch Up Reading Order 
window open, right click on the image and choose Edit Alternate Text > 
add a description of the image. Alternatately from the Accessibility 
tools, choose Set Alternate Text and enter text for all images using the 
arrow keys to navigate. 

Decorative content, such as ornamental images and redundant text, should be set to Artifact so 
screen readers can skip over it. 

With the Touch Up Reading Order window open, select the image by clicking on the square in 
the upper left corner of the image and click the Background button. Alternately you can open 
the tag for the image and right click on the child element and choose Change Tag to Artifact… 
and click OK in the dialog box. You can do this with any element in the tag tree. 

NOTE: 

Images of tables, charts and graphs should be avoided. When they are used, they must include 
a “key take-away” as the alt text 
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V. Data Tables 

For accessibility purposes there are two types of tables. Layout and data. A layout table is used 
to display information visually. A data table has a header row or column and data cells that are 
associated with the header cells. A data table can be simple or complex. Simple tables are only 
required to have their header cells tagged with <TH> tags. Complex tables are additionally 
required to have the header cells defined with a scope and sometimes an ID. 

TEST 

With the Touch Up Reading Order window open, click on any number in any cell of a table and 
click the Table Editor button. Check to make sure the table has the proper cells marked as 
header cells using the <TH> tag. 

REMEDIATE 

Table Editor Options 
By making some color and label selections in the Table Editor Options dialog, the current 
structure of the table can be more visually apparent. 

Accessing and Using the Table Editor Options: 

1. While the Touch Up Reading Order window is active, right click on any table in the document 
and choose Table Editor from the menu. 

2. Confirm the table editor is active by confirming the default red border appears around each 
table cell. 

 

3. Right click in any cell and choose Table Editor Options…  
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4. Put a check in both boxes. The color options are a personal preference. 

 
5. Click the OK button when finished. 
6. Right click a cell to mark it as a header and select Table Cell Properties… 
7. Choose Header Cell in the Type group. If the header row or column spans, add a scope and 

number or rows or columns that are spanned. 

Tagging a Complex Table 
A complex table has more than one header row or column and merges or split cells. The table we 
are using in our example (below) is a complex table listing worldwide TBI numbers for the Army. 
This table is a good example of complexity because the Army and its components are merged 
cells. Each diagnosed case is related to “Severity” and grouped by “Component” under the Army. 

Complex tables must contain scope. Scope denotes which cells are row or column headers and 
identifies the number of rows or columns that are spanned. Each header (TH) will be assigned a 
unique ID and each data cell (TD) will have an array that includes all of the ID values of the 
applicable header cells. 

Screen readers will read a table from left to right and top to bottom. If the data cells are not 
associated with the header cells the table may not make sense when read out loud. 

Table Cell Properties 
Setting the header cells and ID: 

1. With the Table Editor open, right click the cell to mark it as a header and select Table Cell 
Properties… 

2. Ensure the Header Cell radio button is selected. 
3. Select Row, Column, or Both from the Scope combo box. 
4. Adjust the values in the Row Span and Column Span edit boxes as necessary. 
5. Enter a unique name in the ID field that identifies this header cell. 
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Note: It is best to name the ID something relative to what’s in that cell so it is easy to remember 
which ID goes to which cell. 

6. Click OK and repeat for each table header cell. 

Setting the headers array for each data cell: 

1. Right click on the first data cell and select Table Cell Properties… 
2. Ensure the Data Cell radio button is selected in the Table Cell Properties dialog. 

 

3. Navigate to and activate the Add button  for the Associated Header Cell IDs list box. 
4. From the list of available IDs, choose the one that would make the most sense to be read first. 
5. Add the ID for each remaining header in the order that you want them to be read. (A screen 

reader will read each header cell’s contents, not its ID.) This will build a list with the first header 
at the bottom and the last to be read at the top. 

6. When done, click OK. 
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VI. Form requirements 
Ensure every form field has a descriptive tooltip. 

To check or edit the Tooltip of an existing form field, select the Prepare Form button from the 
tools on the right. Then right click the field and select Properties. The Properties dialog box will 
appear. Ensure the Tooltip conveys all the information that a screen reader user would need to 
correctly complete the field. 

Radio buttons 
Radio buttons (a group of options where only one option can be selected) require additional 
information to ensure accessibility. The following information must be provided: 

• The Name must be the same for all of the radio buttons within the group. This groups the options 
together, just like the name attribute for HTML radio buttons. It also allows a keyboard user to 
select an option within the group using the arrow keys. 

• The Tooltip value should also be the same for all radio buttons within the group.  This provides a 
shared label for each of the options, like the <fieldset> and <legend>elements in HTML. Because 
this information will be read for each option in the group, it should be succinct. 

• Under the Options tab, the Radio Button Choice value must match the text that appears next to 
each radio button. 

If these three fields contain the correct information, both the Tooltip and Radio Button 
Choice values will be read by a screen reader. 

Checkbox 
Unfortunately, checkboxes cannot be grouped together in the same way as radio buttons. This 
means that the description of the group of checkboxes and the individual checkbox should be 
presented in the Tooltip. 

Button 
To add text to a button, open the Properties dialog for the button, select the Options tab, and 
then enter the appropriate text in the Label option. If a button does not have a Tooltip, the text 
that appears on the button will be read by a screen reader, but if a Tooltip is provided it will 
override the button text.  

Add Tags to Form Fields 
• Open the Tags pane on the left side of the window, select the Options menu at the top of the 

Tags pane and select Find. 
• In the Find Element dialog, select Unmarked Annotations from the dropdown menu, select the 

Search Document radio button, and then select the Find button. 
• This should highlight the first untagged form field on the page. Select the Tag Element button 

and then the Close button. A Form tag will have to be added for every untagged item. 

Check the reading order. Fields can be rearranged in the Prepare Form pane using drag and drop. 
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VII. Structure of a Link 

TEST 

• Use the Tab key to tab through the document to find all links. This also checks for proper 
reading order. 

• Verify the link text describes the destination, function, or purpose. Text such as ‘click here’ or 
‘read more’ should not be used. Links must also be unique within the document. 

• If an image is used as a link, the alt text can state the destination, function, or purpose 
• Highlight the link text in the document > open the menu in the Tags pane and select Find Tag 

From Selection 
•  The link text and Link-OBJR tag must be under a Link tag 

  

REMEDIATE 

To add the Link-OBJR tag to a link: 

1. Highlight the <Link> tag in the Tags pane. This will allow the tag to be placed in relation 
to its link text. 

2. Right click the <Link> tag and select Find… 
3. In the Find Element dialog, select Unmarked Links from the Find combo box. 

 
4. Click the Find button. 
5. When the link in question is highlighted in the main document by a blue rectangle, click 

the Tag Element button. 
6. Click the Close button. 
7. Confirm a Link-OBJR tag has been placed under the correct <Link> tag. 

If no unmarked link is found the link needs to be manually added to the document. 
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Manually Adding/Editing a Link 
1. In the Tools panel click on Edit PDF, and click the Link dropdown in the Edit tools and 

choose Add/Edit Web or Document Link. 
2. Drag a box around the text to be used for the link. 
3. In the Create Link text box select Invisible Rectangle for Link type and None for 

Highlight Styles. You only have to perform this step the first time you edit a link. 
4. Click the Next button. 
5. Enter the full URL or mailto: link for email addresses and click OK. 
6. Repeat the steps in the previous section to find the untagged link. Be sure the <Link> tag 

is highlighted so the Link – OBJR tab is placed under the correct tag. 

Applying Alternate Text to Links 
This is only needed when a long URL is used instead of descriptive link text, e.g., 
https://dodcio.defense.gov/In-the-News/News-Display/Article/2311483/ambit-gambit-pays-
off-advances-us-5g-efforts/. Alternate text can be applied so that the user will be able to access 
more useful information. Alternate text for the above link should be “Military Hospitals and 
Clinics”. 

1. In the Tags Tree click the plus sign next to the link tag to show the link text and Link-
OBJR tag. 

2. Click on the link text to highlight it. 
3. Right click the link text and select Properties from the menu. 
4. In the Object Properties dialog, place meaningful alternate text in the Alternate Text 

edit field. 

Structure of a Table of Contents 
The table of contents should be structured with the parent 
tag being a <TOC> and a <TOCI> for each table of contents 
item. Each <TOCI> should have a <Reference> tag under it. 
The <Reference> tag should have the link text and a Link-
OBJR under it. In some cases, the link text and Link-OBJR are 
directly under a <Link> tag nested under the <Reference> 
tag. This will work equally as well. 

 

 

 

 

https://dodcio.defense.gov/In-the-News/News-Display/Article/2311483/ambit-gambit-pays-off-advances-us-5g-efforts/
https://dodcio.defense.gov/In-the-News/News-Display/Article/2311483/ambit-gambit-pays-off-advances-us-5g-efforts/
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VIII. Sensory Characteristics 
If an element uses color, size, shape, or location to convey information, the same information 
must be given in text format as well. An example of this is when a bar chart uses a legend with 
colors that match the bars. A simple way to remedy this is to add data labels to the chart, thus 
giving the same information in text format. 

Color contrast must be 4.5:1 for 11-15pt font and 3:1 for 14pt bold or 18pt regular and higher. 
A Color Contrast Analyzer can be downloaded here https://www.tpgi.com/color-contrast-
checker/ . This link is to the developer’s site and is the app the DHS uses in training 508 testers 
in Federal agencies. JSP supported components can request the software from JSP using a 
FORM 7 (Software Request Form). 

IX. Accessibility Checker 
The Accessibility Checker in Adobe is a good tool to check your work. It can be helpful in finding 
list items that are not nested properly or errors in tables. It should not be used as a tool to 
check the document for conformance issues in place of a manual test. The Accessibility Checker 
can check to see if all tagged figures have alternate text, but it cannot tell you if that text is 
meaningful. The Accessibility Checker cannot check the reading order of the document, as well 
as other aspects of accessibility. 

To run the Accessibility Checker: 

1. Under the Accessibility Tools choose Full Check from the options 
2. Make sure all boxes have a check in them under Checking Options 
3. Click the Start Checking button 
4. The report will be displayed on the left side of the window. Open each category that has 

an issue by clicking the plus sign 
5. Remediate each issue found, except for Logical Reading Order and Color Contrast under 

Document. These need to be manually checked. 

  

https://www.tpgi.com/color-contrast-checker/
https://www.tpgi.com/color-contrast-checker/


18 
 

X. Conformant Checklist 
 

Test Condition Page # Pass/Fail 
The document properties: Title, Author & Subject are filled out; Tagged 
PDF set to Yes; Copying for Accessibility set to Allowed; initial view set 
to Document Title; Language is selected 

2-5  

Attachments are accessible 5  
Tag tree: Tags are in proper reading order; Tag type reflects content 
type 

6-8  

Proper heading tags are used and match the visual outline 8  
Lists are properly tagged 8-10  
Meaningful images have Alt Text  10-11  
Data Tables: Header cells are designated; Scope, Span, and ID are used 
in complex tables 

13-14  

Forms: Fields are in the correct tab order; Tooltips are used on all fields 15  
Links: Link text describes the destination, function or purpose; there are 
no broken links; there is a Link-OBJR under each <Link> tag 

16-17  

Color, size, shape, or location is not the only means to convey 
information 

18  

Color contrast between text and background is high 18  
Passes Accessibility Checker with the exception of Logical Reading Order 
and Color Contrast. These can only be checked manually. 
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Further information and training videos on testing and remediating PDFs can be found at 
https://www.section508.gov/create/pdfs/training-videos  

 

https://www.section508.gov/create/pdfs/training-videos
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